Just installed a 'favorite color' mod.

Forum for discussing any additional forums you'd like to see here, or features of the bulletin board you'd like to see enabled or disabled.

Moderator: Extend-A-Story Moderators

Post Reply
User avatar
Sir Toby
Site Admin
Posts: 409
Joined: Sat Apr 26, 2003 3:42 pm
Location: Portland, Oregon, USA
Contact:

Just installed a 'favorite color' mod.

Post by Sir Toby »

In an attempt to cut down on the large number of spam bot registrations on this board, I have coded up a custom mod to try and prevent spam bots from registering. It is a variant of 'The Humanizer' mod I tried a while ago. This mod asks you for your favorite color, giving you a list to pick from. If you don't specify a color that is on that list, you cannot register.

While this is a trivial change, my hope is that by hand-crafting my own anti-spam solution, I will have better luck avoiding spam bots since they'll have to work around my specific solution, which is likely not going to be worth the effort. The problem with using a well known anti-spam mod such as 'The Humanizer' is that as it got more popular, it became worth the effort to work around it, and so most spam bots simply worked around it.

We'll see if this works...
Won-Tolla
Posts: 111
Joined: Sat May 28, 2005 12:38 am
Location: Norway
Contact:

Post by Won-Tolla »

Looks like it may be causing trouble with old registrations. I tried changing something in my profile, but it told me i have to select a favourite colour. The profile page looks just like it used to, there is no list to choose from and no place to enter my choice. So what do I do?
(I tried logging out and back in, nothing out of the ordinary there either.)
User avatar
Sir Toby
Site Admin
Posts: 409
Joined: Sat Apr 26, 2003 3:42 pm
Location: Portland, Oregon, USA
Contact:

Post by Sir Toby »

Okay, I must have screwed something up when I implemented the change. Thanks for the heads up. I'll take a look this weekend.
Won-Tolla
Posts: 111
Joined: Sat May 28, 2005 12:38 am
Location: Norway
Contact:

Post by Won-Tolla »

Any news on this? It still isn't working...

(Outdated signature turned off manually)
Post Reply